EchelonÒ OpenLNS Commissioning Tool ReadMe
Release 4.00, January 2013

Copyright © 2013 Echelon Corporation
All Rights Reserved

1      Overview

This document describes the known problems and workarounds for the OpenLNS Commissioning Tool (CT).  For additional information and updates (including critical updates), go to www.echelon.com/downloads.  For answers to frequently asked questions, see Echelon’s Knowledge Base at www.echelon.com/support.  For the latest OpenLNS CT news, go to www.echelon.com/openlns.

2      Contents

1     Overview.. 1

2     Contents. 1

3     Release Identification. 2

4     Known Problems and Workarounds. 2

4.1          Visio Macro Problems. 2

4.1.1        Corrupted Visio Macro Security Settings. 2

4.1.2        Macros Disabled in OpenLNS CT Drawings Created with the LonMaker® Tool 3

4.1.3        Extra Visio Drawings Opened. 4

4.1.4        Windows Reports Visio has Failed after Closing an OpenLNS CT Drawing. 4

4.1.5        OpenLNS CT Menus not Displayed in Visio. 4

4.2          OpenLNS CT Design Manager Problems. 5

4.2.1        Options not Displayed in the OpenLNS CT Default Options Tab. 5

4.2.2        Different User Account Error 5

4.2.3        System Menu Cannot be Opened in Vista. 5

4.2.4        Bottom of Dialog is not Visible. 5

4.2.5        Imported LonMaker Databases Stored in Different Folders. 5

4.3          OpenLNS CT Drawing Problems. 6

4.3.1        Reference Connection Locations Not Synchronized. 6

4.3.2        Database Access Error 6

4.3.3        Subsystem Names with Ampersands. 6

4.3.4        Invalid RNI Names in Restored Networks. 6

4.3.5        Cannot use Accelerator Keys. 6

4.4          Recovery does not Place Devices in Top-Level Subsystem.. 6

4.5          OpenLNS CT Help Closes with OpenLNS CT Browser 6

4.6          Internet Explorer 9 does not Display OpenLNS CT Network Reports. 7

4.7          LonPoint Plug-in Problems. 7

4.7.1        Superfluous Security Warning Dialog. 7

4.7.2        LonPoint Plug-in Registration Failure. 7

4.8          Names with Multi-byte Characters. 7

3      Release Identification

This ReadMe document applies to the first release of the Echelon OpenLNS Commissioning Tool (CT).  You can verify that you have this release by starting OpenLNS CT, clicking the OpenLNS CT icon in the top-left corner of the OpenLNS Design Manager, and then clicking About Echelon OpenLNS CT.  The About Echelon OpenLNS CT Design Manager dialog appears.  This dialog displays the version number of your OpenLNS CT software.  For the first release of OpenLNS CT, the version number is 4.00.

4      Known Problems and Workarounds

This section describes known problems and their workarounds for this release.  Numbers in parentheses at the end of the descriptions are Echelon's internal problem tracking IDs.

4.1    Visio Macro Problems

4.1.1     Corrupted Visio Macro Security Settings

The Visio macro security settings may become corrupt.  If this occurs, Visio may start without the OpenLNS CT software when you try to start the OpenLNS CT tool.  Workaround: To restore the link to the OpenLNS CT software, follow these steps (select the procedure for the version of Visio that you are using with the OpenLNS CT tool):

Visio 2010

1.      Open the Windows Start menu, point to Program Folders, and then click Microsoft Visio.  Visio starts.  Open an OpenLNS CT drawing file or an OpenLNS CT Visio template file (e.g., C:\Program Files\LonWorks\LonMaker\Visio\LonWorks.vst).  If you see the OpenLNS CT Network Wizard or the OpenLNS CT menu, skip the rest of this procedure.

2.      From the File tab, click Options.  In the Visio Options dialog, click Trust Center, then click the Trust Center Settings button.

3.      In the left column, click Macro Settings.  Confirm that Disable All Macros Except Digitally Signed Macros is selected.

4.      In the left column, click Add-Ins. Confirm that Disable all Application Add-ins is NOT selected.

5.      If you made any changes, exit and re-start Visio and repeat step 1.  If this did not resolve your problem, proceed with step 6.

6.      From the File tab, click Options.  In the Visio Options dialog, click Advanced, and then scroll down until you see the File Locations button.  Click File Locations.

7.      Write down the OpenLNS CT path shown in the Add-ons box, and then delete it.  By default, the OpenLNS CT path is C:\Program Files\LonWorks\LonMaker.  The path may be followed by a semicolon if there are any additional paths in the list.

8.      Exit and restart Visio.

9.      From the File tab, click Options.  In the Visio Options dialog, click Advanced, and then scroll down until you see the File Locations button.  Click File Locations.

10.  Enter the OpenLNS CT path you wrote down in step 5 in the Add-ons box.  Include the semicolon if there are additional paths after the OpenLNS CT path.

11.  Exit Visio and then start the OpenLNS CT tool.  (39839)

Visio 2003

1.      Open the Windows Start menu, point to Program Folders, and then click Microsoft Visio.  Visio starts.  Open an OpenLNS CT drawing file or an OpenLNS CT Visio template file (e.g., C:\Program Files\LonWorks\LonMaker\Visio\LonWorks.vst).  If you see the OpenLNS CT Network Wizard or the OpenLNS CT menu, skip the rest of this procedure.

2.      Open the Tools menu, point to Options, and then click Security.

3.      If any of the check boxes under Macro Security are not selected, select them, click OK, and then exit and restart the OpenLNS CT tool.  If you restart the OpenLNS CT tool and you see the OpenLNS CT menu, skip the rest of this procedure.

4.      Open the Tools menu, point to Options, point to Advanced, and then click File Paths.

5.      Write down the OpenLNS CT path shown in the Add-ons box, and then delete it.  By default, the OpenLNS CT path is C:\Program Files\LonWorks\LonMaker.  The path may be followed by a semicolon if there are any additional paths in the list.

6.      Exit and restart Visio.

7.      Open the Tools menu, point to Options, point to Advanced, and then click File Paths.

8.      Enter the OpenLNS CT path you wrote down in step 5 in the Add-ons box.  Include the semicolon if there are additional paths after the OpenLNS CT path.

9.      Exit Visio and then start the OpenLNS CT tool.  (39839)

4.1.2     Macros Disabled in OpenLNS CT Drawings Created with the LonMaker® Tool

If you open an OpenLNS CT drawing originally created with the LonMaker tool, Visio may display message the following error message: “Macros in this document are disabled because the security level is high…”  If you click OK, the drawing opens, but most of the OpenLNS CT functionality is disabled.  Workaround: To enable the OpenLNS CT software to work with a drawing created with the LonMaker tool, use the following steps to decrease Visio's macro security.

1.      Open the Tools menu.

2.      Click Options, select the Security tab, and then click Macro Security.  A dialog appears allowing you to select Low, Medium, High, or Very High security.

3.      Select Low or Medium security.  If you select Low security, you will be able to open the drawing without a prompt.  If you select Medium security, you will be prompted to enable macros for unsigned network drawings or network drawings signed by companies that have not been added to the trusted signatures list.  

Visio's security level is persistent.  When you change Visio's security level, it will be the security level for Visio every time it is started until you change it again.  Alternatively, you can apply your own company's digital signature to any OpenLNS CT drawings to disable macro warnings for those drawings.  For detailed instruction on how to do this, go to support.microsoft.com.  (40186)

4.1.3     Extra Visio Drawings Opened

When you open an OpenLNS CT document, more than one instance of the document may open in Visio, or additional documents may be opened at the same time.  Workaround: To prevent opening extra drawings, follow these steps:

1.      On the Visio Add-Ins menu (the LonMaker menu in Visio 2003), click Synchronization/Resynchronize.

2.      Select Reset Visio Workspaces.

3.      Click Next.

4.      Select either Only the Current Drawing to update the workspace for the current drawing only, or All Drawing Files in the Network to update the workspace for all drawing files.  (40066)

4.1.4     Windows Reports Visio has Failed after Closing an OpenLNS CT Drawing

When you close an OpenLNS CT document, Windows may infrequently report that Visio has stopped responding after closing the OpenLNS CT drawing.  Workaround: This problem occurs after the OpenLNS CT add-in has properly closed the OpenLNS database and the Visio drawings and then terminated.  As a result, the OpenLNS CT drawing and OpenLNS database are not corrupted, and you can safely close and ignore the error message.  (56976)

4.1.5     OpenLNS CT Menus not Displayed in Visio

If automation events have been disabled in Visio, the OpenLNS CT menus may not be displayed in Visio.  Workaround:  To display the OpenLNS CT menus, follow these steps:

1.       In Visio, click the File tab, and then click Options (on left side).  The Visio Options dialog opens.

2.       In the Visio Options dialog, click Advanced (on left side of dialog)

3.       On the right side of the dialog, scroll to the bottom, and verify that Enable Automation Events is selected under the General heading.

4.       Click OK.  (63602)

4.2    OpenLNS CT Design Manager Problems

4.2.1     Options not Displayed in the OpenLNS CT Default Options Tab 

If you press the ENTER key on the OpenLNS CT Default Options tab, the displayed options will disappear.  Workaround: Either re-select the category or click a different tab in the OpenLNS Design Manger and then re-click the OpenLNS CT Default Options tab.  (41369)

4.2.2     Different User Account Error

If you use OpenLNS CT from a different user account than the one used to install the OpenLNS CT software, the following error message may appear when you initially open or create a network: “Cannot start OpenLNS CT.  If you have run Visio directly, please instead run OpenLNS CT Design Manager…”.  Workaround: Exit Visio, exit and restart the OpenLNS CT Design Manager, and then re-open (or re-create) the network.  If the problem persists, reset the Visio workspaces as described in Corrupted Visio Macro Security Settings.  (23900)

4.2.3     System Menu Cannot be Opened in Vista

If your computer is running Vista, you cannot right-click the title bar at the top of the OpenLNS CT Design Manager to open the system menu in order to view OpenLNS CT software version information, view the Software License Agreement, and refresh and rebuild the device resource files catalog. Workaround:  Click the OpenLNS CT icon in the left corner of the title bar.  (48981)

4.2.4     Bottom of Dialog is not Visible

In some cases, the bottom edge of the OpenLNS CT Design Manager dialog may be clipped. Workaround: Go to the OpenLNS CT Default Options tab, and select the OpenLNS CT font category. Change the Dialog height factor (for example, if it is 1, change it to 1.1). Close the OpenLNS CT Design Manager, then restart and repeat the process, restoring the original Dialog height factor value.  (64882)

4.2.5     Imported LonMaker Databases Stored in Different Folders

If you import a network created with the LonMaker tool into OpenLNS CT, the folders in which the drawings and databases are stored may be different. OpenLNS CT stores the drawings and databases in the C:\Users\Public\Documents\LonWorks\OpenLnsCt folder by default; the LonMaker tool stored the drawings and databases in the C:\LM folder. Workaround: In the General tab of the OpenLNS CT Design Manager, change the selected folder in the Drawing base path field to select whether the OpenLNS CT Design Manager lists the OpenLNS CT networks or the LonMaker networks.  (63419)

4.3       OpenLNS CT Drawing Problems

4.3.1     Reference Connection Locations Not Synchronized

If you move a reference connection in one OpenLNS CT client, other OpenLNS CT clients will not be updated with the new location of the reference shape. Workaround: Replicate the drawing update in all instances of OpenLNS CT, or use the auto-alignment feature.

4.3.2     Database Access Error

If the OpenLNS server does not have read/write access to the folder containing an OpenLNS CT database, you may receive an LCA #22 [DB Access Error #-2032] error message when trying to open that database Workaround: Use the Windows File Manager to browse to the folder containing the network database, which is C:\Users\Public\Documents\LonWorks\OpenLnsCt\Databases\<network name> by default, right-click the folder, and select Properties. Click the Security tab, and then add or edit an entry for “Everyone” with Modify permission.  (67626)

4.3.3     Subsystem Names with Ampersands

If you perform a network merge and the source network contains a subsystem (Visio page) with an ampersand character (&) in its name, OpenLNS CT may report an unexpected error or Visio may fail. Workaround: Remove ampersands from all subsystem names.  (51231)

4.3.4     Invalid RNI Names in Restored Networks

If you back up a network that uses a remote network interface (RNI) and restore it on a different computer, the name of the default network interface for the restored network will be the RNI even if it has not been defined on the current computer (or if the RNI is defined, but references a different device). Workaround: Use the LonWorks Interfaces application in the Control Panel to create an entry for the correct RNI, and then select that RNI when opening the network.  (47073)

4.3.5     Cannot use Accelerator Keys

You cannot use the Accelerator keys to access the OpenLNS CT menu items in the Visio 2010 Add-Ins tab. Workaround: Use the mouse to access the OpenLNS CT menus.  (57703)

4.4       Recovery does not Place Devices in Top-Level Subsystem

If you recover a network, some of the devices in the top-level subsystem may be recovered to a subsystem named “Subsystem 5”, which is not the top-level subsystem.  Workaround:  Move the devices and functional blocks from Subsystem 5 to the top-level subsystem as described in Changing the Subsystem for an OpenLNS CT Shape in the OpenLNS CT User’s Guide.  (41815)

4.5       OpenLNS CT Help Closes with OpenLNS CT Browser

If you open both the OpenLNS CT help and the OpenLNS CT Browser and then close the OpenLNS CT Browser, the OpenLNS CT help file also closes. Workaround: Do not close the OpenLNS CT Browser if you want to continue using the OpenLNS CT help file, or re-open the OpenLNS CT help after closing the OpenLNS CT Browser.  (39570)

4.6    Internet Explorer 9 does not Display OpenLNS CT Network Reports

If you try to use Internet Explorer 9 to view an OpenLNS CT Network Report generated by the OpenLNS CT XML Export utility, the data may not be displayed properly.  This is because security changes in Internet Explorer 9 prevent the use of XSL files to format the content of XML files if the XSL file is not on a secure server.  The XSL file used by OpenLNS CT XML Export is stored locally.  Workaround:  Press F12 to open the Developer Tools, click Browser Mode, and select Internet Explorer 9 Compatibility Mode.  This enables Internet Explorer 9 to display the objects in the report.  Alternatively, you can use an earlier release of Internet Explorer.  (67647)

4.7       LonPoint Plug-in Problems

4.7.1     Superfluous Security Warning Dialog

A security warning dialog may be displayed when opening a drawing that includes the LonPoint stencil.  Workaround: You can safely close and ignore the warning.

4.7.2     LonPoint Plug-in Registration Failure

When OpenLNS CT attempts to register the LonPoint plug-in and the LonPoint resource files are not properly installed, the LonPoint plug-in may display an error message that is hidden behind the Visio window that makes it appear as if OpenLNS CT has failed. Workaround: Minimize the Visio window to expose the LonPoint plug-in error message, and then click OK.  (59536)

4.8       Names with Multi-byte Characters

The OpenLNS CT tool and some plug-ins may fail if devices, functional blocks, or network variables have multi-byte character names.  Workaround: Change the name of the object in the OpenLNS CT drawing and then restart the plug-in.  If that does not correct the problem, do not use a multi-byte character name.  (41701)

 

Echelon, LNS, and LonMaker are registered trademarks of Echelon Corporation in the U.S. and other countries.